一畳のくつろぎタイム

このブログでは紹介する商品画像をAmazonアソシエイトより借りています。画像やリンクにはアフィリエイト広告が含まれる事があります

2024年6月25日火曜日

VMWareWorkstation17.5.2アンインストール後にネットワークにつながらなくなる

 無料になったVMWareWorkstation17.5.2を試した結果、ネットワークインターフェースが使えなくなり1日無駄にしました。

VMWareWorkstation17.5.2アンインストール後にネットワークアダプターが「このデバイスのクラス構成のセットアップをまだ処理しています。 (コード 56)」

となって一切ネットワークへ接続できません。
同じ轍を踏む人はいると思うので、日本人向けに対処法を残します。

本文中、ネットワークアダプター、ネットワークインターフェースやNICなどと表記にぶれがあり読みにくいと思いますが、どれも同じものを指しています。
暇があったら直します。

何をしてこうなったのか

VMWareWorkstation17.5.2が個人利用では無料化し、またHyper-Vと共存できるようになったという情報を得たため試しました。

Microsoft Windows ハイパーバイザー プラットフォーム (WHP) APIという機能で共存可能になったらしい。

WSL2やHyper-Vをバリバリ使用している環境だけど、共存できるなら試してみよっか。

 

共存は可能?

VMWareWorkstation17.5.2を入れて、たしかにVMWareは使うことができました。

しかし共存は出来ずWSL2が動作しない、インターネット上の情報では両方使用できているという方もいるので、何かが異なるのでしょう。

私の環境では共存不可能、セキュアブートやコア分離ができてないからかな?
 

すでにWSL2なしでは生きられないので、 VMWorkstation17.5.2はアンインストールしました。

これが地獄の始まりでした。
この時点ではネットワークインターフェースは使用可能でした。

しかし翌日、WSL2ホストのDockerが起動せず慌てました。
DockerだけでなくほかのUbutuなどのWSL環境も同様に動作しません。 

 

お前の環境は?

OS:Windows10 Pro 10.0.19045
マザー:B450
CPU:Ryzen5
NIC:Realtek RTL8111H オンボード
WSL2利用、Hyper-V利用、昔はVMWarePlayerを利用していた

 

症状

VMWareをアンインストールして、PCの再起動した後、ネットワークインターフェースが、インターネットにつながらなくなりました。
いろいろ方法を試したところ、ネットワークアダプターが

このデバイスのクラス構成のセットアップをまだ処理しています。 (コード 56)

となり全く使用することができない。

では別のUSBネットワークインターフェースや、USBのWifiモジュールなどをつなげばいいじゃないかっと考えますが、どれをつないでも結果は同じ、コード56で使用不可能。


試したが意味がなかったこと

  • デバイスマネージャーからデバイスのアンインストールを行い、リスキャンして再インストール
  • 高速スタートアップ無効ー>最初から無効だった
  • 設定ー>ネットワークとインターネットからネットワークのリセット
  • セーフモードからドライバ更新
RealTekからダウンロードしたドライバインストールしようとすると

If Deep Sleep Mode is enabled Please Plug the Cable. 

といわれる、このキーワードで調べると次の嘘だろって思える方法が見つかるがだめだった。

  • PCの電源を落とし、電源ソケットからプラグを抜いて10分程度放置(メモリは外さなかったけど・・)
  • ネットワークアダプターのランプがついてる確認(windowsが立ち上がると消える)

情報ソース:https://adeelejaz.com/blog/realteks-network-controller-deep-sleep-mode-issue/

正解の対処法を知ってから記事を書いているのでこの時点では、VMWareが原因だから一般的な対処法は意味なくて当然。

 

正解の対処方法

ヒットした解決情報

https://www.reddit.com/r/computers/comments/xhk74q/pc_will_not_accept_any_internet_adapter_giving/

情報の源泉

https://www.reddit.com/r/vmware/comments/18wumeh/error_code_56_on_networks_adapters_vmware_player/

書いている方が、vmware公式/非公式スレッドってどういうこと(中の人?)なのかわからないけど、ありがたい。おかげでPC再セットアップ、開発環境再セットアップせずにすんだ。


対処

源泉のスレッドを見てもらえればわかりますが、

regeditを起動してレジストリから

HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{3d09c1ca-2bcc-40b7-b9bb-3f3ec143a87b}

を削除する

そのあとは、デバイスマネージャーからネットワークアダプターのアンインストールしてリスキャンすれば、何事もなかったようにネットワークアダプターが使えるようになる。

 

情報にたどり着けた検索キーワード

device class setup code 56 hyper-v

こういうのは日本語で調べてもダメなんだよな。